Segment PRO opens plan incorrectly when metric units selected in user defaults

Swansson

New Member
Hello,

I'm a new user

Segment pro 1.1.029
Windows 10
Metric units selected in user defaults

**********************

creating new project (like pic below), then save plan

SegPro_2021-09-29_16-46-50-1.png


******************************

close SPP
open again
when i'm try to open saved plan - see next screenshot

SegPro_2021-09-29_16-48-13-1.png

******************

But I found a temporary solution -
change user defaults again to inches,
open plan (now all dimensions are correct),
than again to metric
:)



please fix this bug,
thanks in advance
 

Attachments

  • SegPro_2021-09-29_16-46-50-1.png
    SegPro_2021-09-29_16-46-50-1.png
    470.1 KB · Views: 3
  • SegPro_2021-09-29_16-48-13-1.png
    SegPro_2021-09-29_16-48-13-1.png
    273.5 KB · Views: 3
Last edited:

mfisher

Super Moderator
Staff member
I rebuilt your plan in SP. I was able to duplicate.
changed setting to metric, built vessel, saved plan, closed sp, opened sp, open planned and it was like your second photo

So I closed SP and opened SP.
Before pulling up the saved plan I made sure the HEIGHT is set to 140mm, ROW , WALL BASE THICKNESS set to 18,10,18 .
Then I opened the saved plan and it pulled up correctly.

I would suggest you send an email to Lloyd. He can explain more precisely why it is happening.
 

Lloyd Johnson

Administrator
Staff member
It’s an easy explanation.

It’s a bug.

The good news is that it won’t be hard to fix. The bad news is that I’m working on some changes that are really hard and are kicking my butt and so I can’t make a simple fix and post it until I either get the other work done or delete the work I’ve done so far. I haven’t decided to give up on it yet and since there is a work around, I suggest you do that until I make my next move.

The other option is to temporarily use Woodturner PRO as it has no such bug.

A couple things to understand - as the only employee, I am not only the programmer but the quality assurance department as well and that is never a good idea. You write software and then test what you’ve written and you miss things that are indirectly related and this is one of them. Since a small percentage of my customers use metrics, it has never gotten the attention it deserves and for that I apologize.

Lloyd
 

Peter1958

PRO Member
I work in metrics too and have that bug also.
When i save the design i always hae the dimensions in the name of the file, like 96, 58, 5, 305 vase. 96 segments, 58 rows, 5 mm thickness of the wood and 305 mm hight. When i want to see the plan again i adjust the parameters and all works again.
But i have something else too: when i design a vessel lets say 72 segments each row and i paint the segments. Then i wanted to enlarge the number of segments into 96, it worked! After painting the other 24 segments each row i went back to the bowl view, then the 24 segments were all not painted anymore. tried what i could, but had to start from scratch.
 

Lloyd Johnson

Administrator
Staff member
First, the good news. I will be able to fix the metrics issue and I’ll get to work on it. Because of the issue I discussed, though, it is going to take me some time so that I don’t lose all the work I’ve done on another issue. It shouldn’t take me too long.

The bad news is the issue of changing the number of segments.

If you change the number of segments after painting them, all bets are off because the database of painted segments no longer matches the display. When this happens, the Summary is no longer correct with regards to the painted segments. I’ve tried a lot of different things to try to allow you to make this change and nothing works 100% of the time. The only thing that works 100% of the time is resetting the segments and repainting. I’ve spent a huge amount of time trying to come up with a way to deal with changes in the number of segments up, down, down/up or up/down and I don’t see a way to make it work.

In a new release, if you change the number of segments and there are segments painted already, you will be given a notice that proceeding will do an automatic reset of the segments if you continue.

The good news is that it takes so little time to repaint any design that it shouldn’t be an issue. Just print a screen capture so you’ll know how to repaint it.
 

Peter1958

PRO Member
First, the good news. I will be able to fix the metrics issue and I’ll get to work on it. Because of the issue I discussed, though, it is going to take me some time so that I don’t lose all the work I’ve done on another issue. It shouldn’t take me too long.

The bad news is the issue of changing the number of segments.

If you change the number of segments after painting them, all bets are off because the database of painted segments no longer matches the display. When this happens, the Summary is no longer correct with regards to the painted segments. I’ve tried a lot of different things to try to allow you to make this change and nothing works 100% of the time. The only thing that works 100% of the time is resetting the segments and repainting. I’ve spent a huge amount of time trying to come up with a way to deal with changes in the number of segments up, down, down/up or up/down and I don’t see a way to make it work.

In a new release, if you change the number of segments and there are segments painted already, you will be given a notice that proceeding will do an automatic reset of the segments if you continue.

The good news is that it takes so little time to repaint any design that it shouldn’t be an issue. Just print a screen capture so you’ll know how to repaint it.
Hello Lloyd,

Now i know it, it is no issue for me anymore.
Thanks for adressing it.

Peter
 

Swansson

New Member
It’s an easy explanation.

It’s a bug.

The good news is that it won’t be hard to fix. The bad news is that I’m working on some changes that are really hard and are kicking my butt and so I can’t make a simple fix and post it until I either get the other work done or delete the work I’ve done so far. I haven’t decided to give up on it yet and since there is a work around, I suggest you do that until I make my next move.

The other option is to temporarily use Woodturner PRO as it has no such bug.

A couple things to understand - as the only employee, I am not only the programmer but the quality assurance department as well and that is never a good idea. You write software and then test what you’ve written and you miss things that are indirectly related and this is one of them. Since a small percentage of my customers use metrics, it has never gotten the attention it deserves and for that I apologize.

Lloyd
+ :)

UPD 2. (Metric mode) Species Lenghts columns in summary tab are in inches (other columns - metric)
please note this in your to-do list :)
 

Lloyd Johnson

Administrator
Staff member
Noted. Thanks.

I will most likely release the next upgrade as a beta release because I’ve had to rewrite a LOT of code. One of the necessary changes will be to require a screen resolution of 1080p (1080 vertical lines). This has been the standard for nearly 5 years but you can still buy laptops with 768 vertical lines. Having to support this resolution punishes the 1080p users and they are by far the majority. I really need the extra real estate that 1080p provides.
 
Top