Saving plans

K

Kfisher

Guest
Not sure what I’m doing wrong. I do a plan in paint. Then crop and save per the video tutorial and it says saved but the plan doesn’t save. I can open the ring view but my new plan doesn’t show up when I open the plan view in segment pro. Any ideas what I may be doing wrong?
Ken
 

mfisher

Super Moderator
Staff member
- Maker sure you are using Save Plan in the Bowl Setting Window. (Bottom of screen) and not the Save Profile at the top left of the screen.
- Have you tried closing SP and restarting the program and see if it is now in the plans list
- When you installed SP in created a My Segment Pro folder, check to see if your *.json file is there.

Bowl Settings
Save Plan
Crop and Save

I went into SP, selected a profile, went into paint and did a design, returned to bowl view, saved the plan
The new plan was there in the list.
 
K

Kfisher

Guest
- Maker sure you are using Save Plan in the Bowl Setting Window. (Bottom of screen) and not the Save Profile at the top left of the screen.
- Have you tried closing SP and restarting the program and see if it is now in the plans list
- When you installed SP in created a My Segment Pro folder, check to see if your *.json file is there.

Bowl Settings
Save Plan
Crop and Save

I went into SP, selected a profile, went into paint and did a design, returned to bowl view, saved the plan
The new plan was there in the list.
I have followed these steps exactly and I also see a saved plan right after saving. However if I exit SP and return it is no longer there. I did check the SP file as you suggested and it is not there either. The PDF for the segments are there but no json files. I am using an older computer with Windows 7. Could that be a potential problem? Everything else seems to be working. I did just get this though so can’t say for certain everything is working as designed.
 

mfisher

Super Moderator
Staff member
I have followed these steps exactly and I also see a saved plan right after saving. However if I exit SP and return it is no longer there. I did check the SP file as you suggested and it is not there either. The PDF for the segments are there but no json files. I am using an older computer with Windows 7. Could that be a potential problem? Everything else seems to be working. I did just get this though so can’t say for certain everything is working as designed.

Windows 7 should not be the issue. I used to run SP on an old XP laptop.
As far as the folder I was mistaken. The My SP folder is where shared (exported) files are placed.

These folders might be hidden on your computer and if they are, you need to click the 'Show Hidden' checkbox in your File Explorer to see them.
The folder where the plans are saved for SP is:
C:\Users\<your username>\AppData\Roaming\Woodturner PRO\Segment PRO
and the two folders are:
Plan
JsonPlan

Likewse, the two folders containing saved Profiles are:
Profile
JsonProfile

When the software starts, it builds the contents of Profiles and Plans by reading each of the files in these four folders.

Likewise the other SP folders and stored data are

C:\users\your user name\AppData\Roaming\Woodturner PRO\Segment PRO\Images

The directories:
JsonCategory.............your categories
JsonPalette................your palettes
JsonPlan....................your plans
JsonProfile.................your profiles

If you continue to have problems I would send Lloyd an email.
 
Last edited:
K

Kfisher

Guest
Windows 7 should not be the issue. I used to run SP on an old XP laptop.
As far as the folder I was mistaken. The My SP folder is where shared (exported) files are placed.

These folders might be hidden on your computer and if they are, you need to click the 'Show Hidden' checkbox in your File Explorer to see them.
The folder where the plans are saved for SP is:
C:\Users\<your username>\AppData\Roaming\Woodturner PRO\Segment PRO
and the two folders are:
Plan
JsonPlan

Likewse, the two folders containing saved Profiles are:
Profile
JsonProfile

When the software starts, it builds the contents of Profiles and Plans by reading each of the files in these four folders.

Likewise the other SP folders and stored data are

C:\users\your user name\AppData\Roaming\Woodturner PRO\Segment PRO\Images

The directories:
JsonCategory.............your categories
JsonPalette................your palettes
JsonPlan....................your plans
JsonProfile.................your profiles

If you continue to have problems I would send Lloyd an email.
Wanted to update this post to let anyone reading it know my issue is resolved. I spoke with Lloyd and he offered some insight. I ended up reloading my Windows 7 and it resolved the issue of saving plans and proiles.
 
Top